Instalar Ubuntu Linux en Dell XPS 8900 (Problema pantalla negra)

El problema venía siendo que la instalación se quedaba en negro nada más comenzar. Encontré este post dónde explica la solución.

  • Iniciar desde el disco de instalación USB.
  • Nada más arrancar, pulsar shift para que aparezca el menú de GRUB.
  • Editar la línea de grup (pulsando la tecla e si estás en modo texto o F6 en modo gráfico).
  • Justo a continuación de quiet splash y antes de las tres rallitas del final ---, introducir el siguiente texto: quiet splash pcie_aspm=off ---

Con esto, al menos de forma temporal, ya no se queda en negro y es posible instalarlo.

El problema es que una vez instalado ya no he visto la forma de volver a hacer aparecer el menú de GRUB y vuelve a salir en negro.

Persistir los cambios

Para conseguir que el cambio sea persistente, volveremos a iniciar desde el Live-CD y ejecutaremos los siguientes pasos:

Montar el disco duro donde instalaste Ubuntu en la ruta /mnt

En mi caso es /dev/sdb1 pero deberías poner la ruta que se correspondiese con tu disco duro. Si no tienes clara cual es, mejor no sigas adelante. Aquí puedes encontrar algo más de información.

sudo mount /deb/sdb1 /mnt

Montar las rutas necesarias para que Grub pueda funcionar

sudo mount --bind /dev /mnt/dev
sudo mount --bind /dev/pts /mnt/dev/pts
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys

Ejecutar chroot

sudo chroot /mnt

Editar el fichero /etc/default/grub y volver a añadir la opción pcie_aspm=off

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=off"

Ejecutar la orden update-grub

update-grub

Salir de chroot:

exit

Desmontar las rutas

sudo umount /mnt/dev/pts
sudo umount /mnt/dev
sudo umount /mnt/proc
sudo umount /mnt/sys
sudo umount /mnt

Con esto (casi nada) ya quedaron los cambios persistentes.

Deja un comentario

Deja un comentario